Tanksäulenumbau (Teil 2)



Nachdem uns der erste Umbau so gut gelungen ist, und wir beim E-Mobilistentreffen für Hamburg und umzu (für Nichtbremer: umzu = Umland) so einen enormen Zuspruch erhalten haben, wollen wir es jetzt noch mal wissen. Als erstes geht es auf die Suche nach einer "alten" Tanksäule. Ideal ist ein Baujahr zwischen 1985 und 1990. Wichtig: Die Anzeigeeinheit sollte noch funktionieren, denn sie soll wie im Original auch weiterhin genutzt werden. Nicht benötigt werden der Pumpenbereich und alles was direkt mit dem Kraftstoff zu tun hat. Unter anderem fallen also auch die Schläuche mit den Zapfpistolen weg.

So fragt man also Freunde und Bekannte und sucht im Internet. Was allerdings teilweise im Internet für Preise für die Säulen verlangt werden ist teilweise ziemlich heftig. Ich frage mich, ob das gerechtfertigt ist. Vielleicht noch vom Schrottwert, aber dafür muß ja auch einiges entsorgt werden. Und wenn dann jemand 800,- pro Säule haben will, die man dann auch noch abbauen darf, dann habe ich da wahrscheinlich ein anderes Preisgefühl.

Nunja, trotzdem sind wir im Internet fündig geworden und haben zu einem lukrativen Preis eine Gilbarco Säule von 1988/1989 erstanden. Bei der Gelegenheit habe ich zum erstenmal festgestellt wie breit Niedersachsen eigentlich ist. Aus dem Raum Bremen, bis in den Bereich Lüchow-Dannenberg ist es schon eine Kleinigkeit von Strecke.


Treiberstufe

Das Rechenwerk der Säule wird durch diese Treiberstufe vom Raspberry Pi angesteuert. Links befindet sich die Ansteuerung der Power LEDs, die links und Nachdem die Edelstahlfedern erst einmal entfernt wurden, war die Säule dann auch nicht mehr ganz so schwer. Aber immer noch schwer genug. Schlüssel gab es dazu, Dokumentation nicht. Das das zu einem kleinen Problem werden könnte, zeigte sich dann in Bremen. Die Säule mit Strom zu versorgen war nicht problematisch, weil das Netzteil klar definierte Eingänge hat. Damit leuchtete schon einmal das Display. Erfolg!

Die Säule wurde am Pfingstmontag abgeholt. Und noch war sie gefüllt mit jeder Menge Pumpentechnik, Filtern usw. die nun nicht mehr benötigt wurden. Carsten hat den folgenden Samstag dann ganz alleine für sich und die Säule gehabt und die dankbare Aufgabe, den Pumpenraum zu entkernen. Und dafür hat er dann auch den ganzen Samstag benötigt. Alles war voller Benzin und damit auch nicht besonders sauber. Schrauben und Muttern waren teilweise gut versteckt und manche Teile hingen seltsam verbunden ineinander.
entkernter Pumpenraum

Als dann aber am Samstag die Dämmerung einbrach, war das Tagwerk getan, und der Pumpenraum entkernt.
Nun sollte aber auch der Preis neu eingegeben werden können. Außerdem wäre es schön, wenn man die aufgelaufenen Werte im Display zurück setzen könnte.

Glücklicherweise hat Gilbarco eine recht umfangreiche Dokumentation im Internet veröffentlicht. Leider so umfangreich, das man sehr lange suchen darf, wenn man nicht weiß wie die Säule heißt. Es gab kein Typenschild mit Bezeichnung und Seriennummer auf der Säule. Nach einigem suchen stellte sich heraus, das es sich wohl um das Modell "Legacy" handeln müßte. Danach in der Dokumentationsdatenbank zu suchen war schon weitaus einfacher.

Und bei den etwa 20 Dokumenten gab es zwar keine detailierte Anschlußbeschreibung, aber immerhin ein Benutzerhandbuch. Und da stellte sich auch mit einmal heraus, warum die "F1"- und die "2"-Taste stärker verschmutzt als die anderen Tasten am Rechenwerk waren. Mit F1 und 4 mal der 2 (Passwort) konnte man das Rechenwerk einstellen. Unter anderem konnte man hier also den Preis einstellen.
Wenigstens etwas. Leider konnte das Zählwerk im Display immer noch nicht zurück gesetzt werden. An der Stelle, wo ursprünglich die Zapfpistole eingehängt wurde ist ein Kontakt. Und dieser Kontakt war auch in der Anschlußkiste wieder zu finden. Nur leider reagiert die Säule dort nicht mit einem zurücksetzen. Es tut sich zwar etwas in der Anzeige, aber nachdem der Kontakt wieder in den ursprünglichen Zustand gekommen ist, zeigte auch die Anzeige eben diesen....  Keine Nullen, die darauf warteten sich langsam zu steigern.

Eine Anfrage an eine Servicestelle von Gilbarco hat nichts gebracht. Nicht mal den Hauch einer Antwort. Diese Erfahrung hatten wir an der ersten Säule auch schon gemacht. Ich kann es den Leuten nicht einmal verdenken.... aber wie heißt es so schön, man trifft sich immer zweimal im Leben. Bin gespannt, ob  das hier auch passiert. Dann habe ich Ralph aus dem GoingElectric Forum angefragt, weil er mir beim E-Mobilisten-Treffen in Sehnde gesagt hatte, das er in dem Bereich mal tätig war, und der hat mich auf den richtigen Pfad gebracht.

Diese Säulen haben mehrere Betriebsmöglichkeiten. Ich sollte mal schauen, ob man die autark betreiben kann. Es könnte sein, das die Säule ursprünglich an einer Konsole angeschlossen war, und dann kann sie auch nur von dort aktiviert werden. Und genau das war das hüpfende Komma, der springende Punkt: Standalone hieß das Zauberwort bei Gilbarco, und das konnte man genauso wie den Preis umstellen.

Kaum war das gemacht, ging die Anzeige auf 0.00 und die Impulse tröpfelten ins Display.

Nun hat man sich während der Suche nach der Ursache nicht ausgeruht. Es gab noch einiges anderes zu tun. Der Pumpenraum wurde komplett entkernt. Nur die sogenannte AC-Junction-Box war am Ende vorhanden. Dort ist der Stromanschluß und die Schnittstelle zum Rechenwerk untergebracht. Außerdem ging es jetzt auf die Suche nach Kabeln für 43kW mit passenden Typ2 Steckern (weiblich, Fahrzeugseite).



Zähler bekommen wir diesmal direkt von Easymeter. Sie haben eine 100A Lastgrenze und einen D0-Datenausgang.

Als nächstes muß man sich Gedanken machen um die Anschlußtechnik. Diesmal soll keine Telefonanbindung mit intergriert werden (wäre technisch aber ein Klacks), dafür soll durch den Anschluß des Kabels der Ladevorgang sofort starten.
Außerdem gibt es noch Probleme zu lösen: Muß bei einem 63A Anschluß ein TypB Fehlerstromschutzschalter eingebaut werden oder nicht? Laut diverser Dokumentation für Hausinstallationen ist das z.B. nur bis 32A notwendig. Durchlauferhitzer in Haushalten müssen üblicherweise nicht in den Stromkreis eingebunden werden.

Persönlich bevorzugen wir den Einbau. Sicher ist sicher. Nur bei Preisen von über 500,- pro Gerät (und wir benötigen zwei) ist das natürlich ein Pfund, das es zu heben gilt.

Es bleibt dabei die Frage, ob dafür nicht die Hausinstallation zuständig ist, an der die Säule am Ende hängt? Die E.ON-Wallbox z.B. hat auch keinen Schutz integriert. Dort gibt es den FI und die Sicherung als extra Paket, weil sie laut Anleitung auch direkt hinter dem Hausanschluß und NICHT hinter einem evtl. vorhanden TypA-FI verbaut werden darf.

  Reinigung

 
Während der Rahmen des Pumpenraums gesandstrahlt wurde, wurde das Rechenwerk aus seinem Rahmen entfernt. Und dann waren da noch die Edelstahlbleche. Besonders das Blech, das die Oberfläche zum Pumpenraum abschließt sieht schlimm aus.
Rost und Schmutz, Klebereste usw. mussten entfernt werden. Tja, und wie bekommt man das weg? Ein Tipp: mit Essig. Ein anderer Tipp: Sandstrahlen. Und dann noch: Schleifpapier.

Um was handelt es sich hier? Edelstahlblech. Und das ist identisch mit dem Zeug, aus der in der Küche normalerweise die Spüle besteht.

Also müßte es doch mit Küchenreinigungsutensilien zu machen sein. Und tatsächlich, mit dem richtigen Reinigungsmitteln klappt es. Allerdings nicht irgendwelche, sondern Profireiniger muß her. Im Gastrobereich gibt es Krustenentferner. Das Zeug ist sehr ätzend und sollte nur außen versprüht werden, weil auch einatmen ziemlich unangenehm ist. Handschuhe sind obligatorisch. Aber nach einiger Zeit des einwirkens bekommt man nach dem schrubben mit einem Topfschwamm die Oberfläche im Original zu sehen.









Die Seitenbleche und auch die Schaugläser haben jetzt eine gründliche Reinigung hinter sich. Da riecht nichts mehr nach Benzin oder Diesel. Die Schaugläser waren sehr verschmutzt und jetzt sehen sie aus wie neu und können für neue Aufgaben eingesetzt werden. Mal sehen, wie wir den Strom kanalisieren, damit wir ihn hier sichtbar machen können.

Steuertechnik


Auch in dieser Säule wird ein Raspberry Pi für die Aktivierung der Anschlüsse, die Anzeigeverwaltung und die Ladekurvenauswertung verantwortlich sein. Nachdem wir in der ersten Säule bereits ein Gehäuse von Pollin eingebaut haben, haben wir jetzt mal geschaut, ob es noch Alternativen gibt. Und tatsächlich, es gibt die Möglichkeit den Raspi hochkant in ein Hutschienengehäuse einzubauen. Dadurch wird richtig viel Platz gespart.





Aufarbeitung


Die Displayeinheit, die das Rechenwerk trägt (und die beiden Federarme) war teilweise doch recht verrostet und an manchen Stellen demoliert. Was aber ein richtiger Handwerker ist, der bekommt so etwas in den Griff.


Etwas Spachtel, einige Zeit schleifen, und dann eine Lackierung, das einem ganz weich ums Herz wird. Die Einzelteile nehmen langsam Gestalt an. Der ehemalige Pumpenraum hat von den Sandstrahlern schon seinen Schutzanstrich bekommen. Als nächstes wird auch er hübsch gemacht.


Treiberstufe

Das Rechenwerk der Säule wird durch diese Treiberstufe vom Raspberry Pi angesteuert. Links befindet sich die Ansteuerung der Power LEDs, die links und rechts in die Schaugläser kommen. Es hat sich gezeigt, das die Leuchtkraft der 3W PowerLED selbst bei Sonnenlicht ausreicht.
Getrennt wird der Leistungsteil durch 4 Optokoppler. Pro Schauglas werden 2 LEDs aktiv sein.
In der Mitte der Treiberstufe befinden sich zwei Relais, die die beiden Zählwerke im Rechenwerk zurück setzen. Die Anschlüsse befinden sich nach rechts heraus. Oben links werden die Impulsgeber angesteuert.
Am unteren Rand der Platine befinden sich die Eingänge die mit den Steuersignalen des Raspi versorgt werden.

Power-LED

Die ursprüngliche Idee war einmal in das Schauglas mit "Blasenfrei zapfen" eine Backofenleuchte einzubauen. Denn genauso wie diese Backofenleuchten sehen die Schaugläser aus. In dem Moment, wo der Schütz anzieht, sollte diese Leuchte angehen. Dadurch kann man dann sehen, das Strom am Kabel anliegt. Dann kam die Idee, durch Blinkimpulse die im Moment geladene Stromstärke anzuzeigen. Da war dann aber die Schwierigkeit, wie man das realisieren sollte. Platz für zwei Glühlampen ist nicht vorhanden, außerdem hätte man das Gehäuse bzw. die Lampen gut gegen die Stromzuführung (die dort 230V betragen hätte) schützen müssen. Also musste eine andere Idee her. LED war das Zauberwort. Nur, wären die hell genug, das man sie auch im Sonnenlicht sehen könnte. Ohne das man direkt hineinschauen muß? Das konnte man nur durch einen echten Test herausfinden.... siehe Bild:


Es handelt sich hierbei um 3W-RGB LED. Davon werden hier jetzt nur die rote und die grüne LED genutzt. Je nach Ausgangssignal auf dem Raspi leuchtet entweder die grüne oder die rote LED. Sobald der Schütz für das Typ2 Kabel anzieht, bekommt die RGB-Power-LED Strom und die grüne LED leuchtet. In dem Moment wo Strom fließt wird auf die rote LED umgeschaltet. Und je mehr Strom fließt, desto häufiger wird geschaltet.

Anzeige/Rechenwerk Erste Tests

Die Gilbarco ist etwas zickig gewesen. Nachdem die Treiberstufe grundsätzlich funktionierte, gab es zu Anfang noch die Fehlermeldung 40. Nachdem dieser Fehler dann behoben war, wurden die Steuerimpulse nicht angenommen. Die Säule befand sich aber schon im Standalone-Betrieb.
Nach einiger Zeit fand ich dann heraus, das die "Zurücksetz"-Sequenz nicht 100%ig stimmte.
Nach einiger Programmierung klappte es dann. Das Zählwerk zählte. Nur seltsamerweise stand dort ständig der Fehler 44. Laut Handbuch war das ein Fehler, der mit dem Einschalten zusammen hing. Es mußte also darauf geachtet werden, das der Raspi schnell genug die Relais in die richtige Stellung bringt. Dafür hat er aber auch reichlich Zeit. Bis das Rechenwerk bereit ist, kann es schon mal bis zu 90 Sekunden dauern. Das Ergebnis danach kann sich aber sehen lassen, wie erste Tests beweisen:


Die Zeit nutzen...

Die Zeit "zwischen den Jahren" muß natürlich auch sinnvoll genutzt werden. Und irgendwie soll die zweite Säule noch im Jahr 2014 fertig werden. Leider wird das nicht komplett klappen, aber zumindest äußerlich und im Hochspannungsteil wird zu 99% alles bereit stehen, und man wird die Säule auch schon nutzen können.


Carsten ist hier bei der Platte bei der Verdrahtung dabei. Wie man bei genauem hinschauen erkennen kann, wird die Säule zwei Ladestränge haben. Geplant ist ein Strang mit max. 32A und einer mit max. 63A. Anschlußtechnisch wird es möglich sein, die volle Ladung mit einem 63A und einem 32A Kabel zu erhalten. D.h. mit 95A kann man beide Anschlüsse voll nutzen. Da solche Anschlußvielfalt selten anzutreffen ist, gibt es aber auch die Möglichkeit, die Säule nur mit 63A oder sogar nur 32A zu nutzen. Dadurch steht dann zwar nicht die volle Leistung auf beiden Seiten zur Verfügung. Aber bei z.B. einem 32A Anschluß können 2 BMW i3 mit voller Ladung versorgt werden, weil auf der einen Seite die 32A auf L1 und auf der anderen Seite auf L2 zur Verfügung steht.

Um z.B. zwei  Zoe optimal laden zu können, wird ein Lastmanagement eingesetzt. Sollte ein Zoe nicht mehr die volle Leistung benötigen, dann steht die Differenz am zweiten Ausgang zur Verfügung. Die Steuereinheiten kommunizieren mit den Zählern.

Das Rechenwerk arbeitet bereits wie erwartet. D.h. die Zählimpulse von den Zählern werden bereits korrekt umgesetzt. Der aktuelle Stromfluß wird mit Power-LEDs an den Schaugläsern angezeigt. Sobald der Schütz für das Fahrzeug freigeschaltet ist leuchtet das Schauglas grün. Je mehr Strom fließt, desto häufiger wird auf "Rot" umgeschaltet.

Zur Beleuchtung des Typenschildes (also da, wo vorher Normal/Super stand) sind je Seite eine Leuchtstoffröhre verbaut. Diese mußten aber erst einmal neu besorgt werden, weil die Originalröhren fehlten. 
 
Beim Zusammenbau von Rechenwerk und Säulenkorpus wurde dann auch gleich geprüft, ob die Röhren funktionieren. Auf der einen Seite klappte alles wunderbar, während sie auf der anderen Seite nur dunkel vor sich hinglimmte. Da muß also etwas defekt sein. Erst einmal die Röhren gegeneinander getauscht. Dabei kam dann heraus, das wohl die Startertechnik nicht in Ordnung ist. Also das Modul für die Beleuchtung aus dem Rechenwerk zerlegen und nachschauen, was da los ist.
Die Überraschung war groß, als dann der total verschmorte Starter für die Röhre zu sehen war. Nach dem Austausch liefen beide Seiten der Beleuchtung in gewohnter Qualität.






Die Hardware steht


Carsten hat sich viel Mühe gegeben. Denn nicht nur die Platte im Schaltschrank musste verdrahtet werden, auch der Rest der Säule will angeschlossen sein. Die dicke Zuleitung für maximal 63A geht natürlich auch gleich an den Leitungsschutzschalter. Das gibt dicke Oberarmmuskeln.

Die 32A Seite ist extern noch nicht verkabelt.

Beim ersten einschalten dann die Enttäuschung. Die 32A Seite zeigt alles korrekt an, aber an der 63A Seite zeigt die Säule "Fehler 40" an. Eigentlich eine Meldung des Rechenwerks, das keine Informationen von extern (also vom Raspi kommen). Also erst mal den Raspi gestartet. Tja, nur will der sich partout nicht starten lassen. Also wieder nach Hause fahren und eine neue SD-Karte programmieren, weil man clever wie man war, von der ersten, die nun mittlerweile fehlerhaft ist kein Backup gemacht hat. Glücklicherweise war nur die Boot-Partition defekt, die Daten-Partition war in Ordnung. Bei der Gelegenheit habe ich dem Edimax-USB-WLAN Modul beigebracht als Accesspoint zu arbeiten. Das hat den Vorteil, das einerseits die Säule extern einfach mit einem Laptop konfiguriert werden kann, andererseits kann man aber auch die Ladekurven nach erfolgter Ladung anschauen. Dazu bucht man sich einfach mit seinem Smartphone an der Säule ein und geht mit seinem Internetbrowser auf die Webseite http://192.168.11.2.

So, neue SD-Karte rein, Säule gestartet....  immer noch Fehler 40. Immerhin kann jetzt der Raspi aber schon von außen konfiguriert werden. Es ist also nicht notwendig eine externe Tastatur und einen  Monitor anzuschliessen. Das klappt jetzt locker mit einem Laptop.

Also, woher kommt der Fehler. Erst mal Testimpulse und Resetsignale zum Rechenwerk geschickt. Auf der 32A Seite klappt alles. Die 63A Seite führt zwar Resets aus, zählt aber nicht und zeigt weiterhin "Fehler 40". Also die Zuführungen vom Raspi von Seite 1 (63A) auf Seite 2 (32A) getauscht. Ergebnis: "Fehler 40" auf Seite 1. Also muß der Fehler im Rechenwerk liegen. Dort die Kontakte geprüft. Bei einem Kabel sieht der Anschluß schon etwas seltsam aus. Also durchmessen.... Alles in Ordnung. Platine herausnehmen....  Was soll das bringen? Wir haben doch sowieso keine Schaltpläne. Egal. Alles untersuchen. Und siehe da, diese Platine enthält ein ganzes Sammelsurium von Sicherungen (mindestens 16 Stück). Und eine von diesen Sicherungen war defekt. Also Sicherung getauscht, Säule mit Strom versorgt und eine gute Minute gewartet. Taataa ...  der Fehler ist weg und die 63A-Seite funktioniert wie sie soll.
Dann die nächste Hürde. Der Preis soll geändert werden. Dazu muß an der Säule über eine Folientastatur erst einmal F1 und dann das Passwort 2222 eingegeben werden. Nur reagiert die Säule da auf nichts. Kontakte an der Folientastatur durchmessen bringt auch kein echtes Ergebnis. Die Taste 1 und die Taste 4 reagieren. Sonst ist alles tot. Heißluft auf die Folie und das Teil zerlegen um zu sehen, wo was ist. Tatsächlich kann mit dem Meßgerät an keiner Stelle Durchgang gemessen werden. Keine Ahnung, was da nicht in Ordnung ist. Nach einem Init-Impuls vom Raspi und dem direkten brücken mit Hilfe eines Drahtes ging es dann mit dem programmieren. Ich werde mich jetzt auf die Suche nach einer Ersatztastatur machen. Außerdem spiele ich mit dem Gedanken über einen USB->8 Kanal Schalter für den Raspi die Tastatur auch über den Raspi erreichbar zu machen. Das dürfte letztlich auch einfacher sein, als sich mit dieser Folientastatur rumzuquälen. Damit wäre auch dort die Funktionalität zur Original-Benzin-Säule verbessert.

Blöderweise hatte ich vergessen die Steuerplatinen für die Regelelektronik mit Software zu bespielen. Deswegen liefen die Displays der beiden OpenEVSE Platinen nicht. Gemeinerweise war mir das im Vorfeld nicht bewusst und so hat Carsten einen vormittag damit verbracht herauszufinden, warum die Displays nichts anzeigten. Jetzt war aber alles gut.

Dann noch einen Fahrzeugsimulator anschließen und der Schütz hat angezogen. Dadurch ging dann auch die Power-LED an. Oben beim ersten Bild kann man es in Grün sehen. Heißt: Säule bereit, Strom liegt am Ausganganschluß an.
Rotlicht heißt: es fließt Strom. Und je mehr "Rot", desto mehr Strom.


Die beiden SDM630 Zähler hängen jetzt gemeinsam an einem RS485 Anschluß am Raspi. Auswerten kann ich sie schon. Jetzt muß ich noch ein klein wenig in die Programmierung einsteigen, damit das Rechenwerk mit Daten versorgt wird und damit die Power-LED je nach Leistung "Rot" anzeigt.

Und die Power-LED verdienen ihren Namen zu recht. Da kommt ganz schön Power raus. Das muß aber auch klappen, denn auch bei Sonnenschein muß man das ja erkennen. Und hier sieht man schon gut, welche Leistung dahinter steckt. Obwohl die Schaugläser praktsich "klar" sind, leuchten sie grün bzw. rot.







Mittlerweile ist die Ladesäule in Betrieb gegangen und auch regelmäßig bei E-Auto-Treffen dabei. Dazu wurde extra eine Transportbox konstruiert. Damit kann die Säule dann im Kangoo ZE zum Zielort gebracht werden.


Ladesäule on Tour


16.09.2017 Triple Dille, Bruchhausen Vilsen, Restaurant Dillertal





In der Ausgabe 4/2017 des Make-Magazins wurden die beiden Säulen vorgestellt:

https://www.heise.de/select/make/2017/4/1503860616012345


Kommentare:

  1. Mir ist aufgefallen, dass in der Anzeige "Preis je kWh" 0,32 CENT angezeigt wird, obwohl es 32 CENT sein müssten. Oder alternativ, wenn das Komma in der Anzeige nicht versetzt werden kann, die Beschriftung von CENT auf EURO wechseln..

    Grüße aus Bremen
    Ulrich

    AntwortenLöschen
    Antworten
    1. ja, das stimmt. Ist ein Fehler. Hing damit zusammen, das bei der ersten Säule tatsächlich 32,9 cent genutzt wurden.
      Als ich die Schilder neu machen ließ, lief das Rechenwerk noch nicht. Momentan steht uns auch nicht der Sinn danach es wieder zu ändern.
      Das mit dem ändern ist nicht ganz einfach. Denn vom Rechenwerk her kann man den Dezimalpunkt nicht verschieben. Es bliebe nur das überkleben oder 4 neue Gläser herstellen zu lassen. Überkleben sieht "Kacke" aus und ganz billig sind die Gläser auch nicht. Also wird wahrscheinlich erst mal alles beim Alten bleiben.
      Du bist der Erste, dem es aufgefallen ist (wir wußten es kurz nachdem alles zusammengebaut war). Und bisher hat noch NIE jemand den angezeigten Betrag bezahlt :-) Ist also alles gar nicht so schlimm.

      Löschen